← Back to status

Minor incident · Resolved

Degradation of MTN AI Platform

Minor severity · Started Aug 14, 2026 · 09:00 UTC · Resolved Aug 15, 2026 · 00:51 UTC · Lasted 15h 51m

Affected components

  • MTN AI Platform

Updates

Resolved — The fix has been deployed.

Identified — We have identified the issue and are working on a fix.

Investigating — We are aware of a small degradation in performance and an increased request failure rate on MTN AI Platform and are investigating the issue. The platform remains usable, while some request might take longer than usual to complete. We will update here as soon as we have additional information.