← Back to status

Major incident · Resolved

Issues with MTN AI and MTN Webpanel services

Major severity · Started Jun 30, 2026 · 15:43 UTC · Resolved Jul 2, 2026 · 10:04 UTC · Lasted 42h 21m

Affected components

  • MTN Media Webpanel
  • MTN AI Platform

Updates

Investigating — We are still seeing some requests failing on these services and will continue to investigate. 

Monitoring — We have located the issue at an upstream service provider and have worked with them to implement a fix. We are now monitoring if this has resolved the issues.

Investigating — We are aware of issues with MTN AI and MTN Webpanel services and are actively investigating the cause of these disruptions.