← Back to status

Major incident · Resolved

Outage of MTN AI Platform

Major severity · Started Jul 2, 2026 · 10:05 UTC · Resolved Jul 2, 2026 · 18:36 UTC · Lasted 8h 31m

Affected components

  • MTN AI Platform

Updates

Resolved — This incident is resolved

Identified — We have identified a few additional minor issues in connection to the fix and have deployed a version to also address these. We will continue to monitor the results.

Monitoring — We have identified the issue and deployed a fix. We are now monitoring the situation.

Investigating — We are currently experiencing an outage of our MTN AI Platform where users are unable to login. We are already working to resolve this issue.